Jump to content
Sign in to follow this  
Romuluz

Alienware 13 R3 Intel HD und GTX1060 beissen sich

Recommended Posts

Hallo zusammen,

vorne weg Entschuldigung für den etwas bescheuerten Threadtitel, ich weiß nicht wie man das in wenigen Worten genauer beschreiben kann. Auch bin ich mir nicht sicher ob es sich hier wirklich um ein Hardwareproblem handelt oder ein Softwareproblem, kann beides sein.

 

Also: Ich hab es für eine gute Idee gehalten mir ein AW 13 R3 zu kaufen, weil ich ein kleines Notebook mit viel Leistung zum gamen haben wollte. Soviel zur Theorie...

 

Konfig:

Intel i7-7700HQ/Intel HD Graphics 630

16GB RAM

GTX1060, 6GB RAm

Monitor WQHD OLED Touchscreen

 

Mein Problem ist, das die Intel HD Grafikkarte anscheinend das gesamte System stört. Beispiele hierfür:

-Programm Future Pinball kann nur in 1360x768 gestartet werden, bei höherer Auflösung sieht man nur noch ein Viertel des Bildes (oben Links) auf den ganzen Bildschirm skaliert.

-Programm Pinball Arcade erkennt in den Settings nur die HD 630

-Fallout 4 konfiguriert sich selbst beim erstmaligen Starten nach Installation mit "niedrigen Einstellungen" weil es die Intel statt der GTX erkennt.

und noch ein paar andere Programme die ähnlich reagieren.

Bei Fallout kann ich die Einstellungen von Hand auf hoch ändern, er spielt es dann anscheinend auch auf der GTX ab (hoffe ich)

IN GPU-Z wird nur die Intel HD angezeigt. Dies ist auch so, wenn ich die Intel HD im Gerätemanager ausschalte.

Ich habe dann noch folgendes eingestellt: Globale Einstellungen/Bevorzugter Grafikprozessor -> NVIDIA Hochleistungsprozessor

Weder das, noch das abschalten der Intel HD ändert was. Auch der Start eines Programmes mit Rechtsklick, Mit Grafikprozessor ausführen, -> NVIDIA... ändert nichts am verhalten.

Folgende Änderungen ergeben sich, wenn ich die Intel HD ausschalte:

-Programm Pinball Arcade zeigt bei den Settings nun "Microsoft Basic Display Driver DISPLAY9 (Primär)" an. Die GTX kann nicht ausgewählt werden.

-Das System hängt nun dauerhaft auf 2560x1440 fest und kann nicht geändert werden.

Und noch eines: Im BIOS habe ich keine Einstellungen gefunden die es mir ermöglicht die Intel HD abzuschalten oder die GTX als "führende" Graka einzustellen.

 

Sind das bekannte Probleme? Gibt es einen Workaroud?

Ach, eines noch... Sofern die Intel HD aktiviert ist kann ich in den NVIDIA Einstellungen nur die 3D Einstellungen sehen, Bildeinstellungen, 3D Einstellungen, Surround etc. Alles andere das man von NVIDIA kennt gibt es nicht. Also die Sachen unter Anzeige, etc... Wenn ich die Intel HD ausschalte, dann gibt es gar keine Einstellungen mehr. Alles leer.

Gruß

Romi

Share this post


Link to post
Share on other sites
Posted (edited)

Also mir ist ein solches Verhalten bei meinem kleinen Alien nicht bekannt. Du könntest beim Boot-Vorgang mal die FN Taste drücken und einen erweiterten Systemtest durchführen. Dann weißt du zumindest ob die Hardware einen Fehler/Defekt hat oder nicht.

Ansonsten alle Grafiktreiber deinstallieren und neu instalieren. Sollte das nicht helfen System neu aufsetzen.

Edited by CMMAP

Share this post


Link to post
Share on other sites

@Romuluz:

Dazu eine Frage zum allgemeinen Zustand von Windows. Handelt es sich denn noch um die originale Werks-Installation, oder wurde bereits von dir alles komplett neu installiert oder diverse Treiber ausgetauscht bzw. diverse Einstellungen verändert, auch im Bios? So etwas wird nämlich oftmals sehr gerne verschwiegen oder unter den Tisch gekehrt, darum frage ich das :) . Wie ist das denn bei deinem Gerät generell vorgesehen? Gibt es da eine Funktionstaste, mit der du manuell zwischen beiden Karten hin-und her schalten kannst je nach Bedarf, oder gibt es bei deinem Gerät gar keine Möglichkeit, auf die Wahl der Grafikhardware Einfluss zu nehmen und das System das immer selber entscheidet ?

Gruß

Jörg

Share this post


Link to post
Share on other sites

@CMMAP

Beim ePSA Boottest werden keine Fehler gemeldet. Grafiktreiber neu installieren war das erste was ich versucht habe, System neu installieren das nächste.

 

@Jörg

Womit deine Frage nach einer Neuinstallation auch schon behandelt wäre. Treiber bei der Neuinstallation habe ich von der passenden Dell Support Page genommen. Zum Thema BIOS: Es laufen die Default Werte. Lediglich TPM wurde deaktiviert.

Wenn ich die Taste für das Umschalten der Graka drücke, dann erzählt mir das OSD: "Not supported with OLED LCD Panel"

Google hat mir auch noch das hier rausgesucht: Dell Support

Scheint als hätte ich mal wieder ins Klo gegriffen... :(

 

Das hier ist auch noch interessant: Das Video geht auf Probleme mit Intel und NVIDIA Grakas ein. Lösung hier ist das vollständige abschalten der Intel HD im BIOS. Aber das ist leider anscheinend beim AW 13 R3 nicht möglich.

How To Completely Disable Intel HD Onboard CPU Graphics - HP Laptop

Share this post


Link to post
Share on other sites
Posted (edited)
vor 10 Stunden schrieb Romuluz:

habe ich von der passenden Dell Support Page genommen

Beschränke dich mal auf die Treiber von den Kartenherstellern. Also:

1060 GTX Treiber

Intel HD 630 Treiber

Zitat

Lediglich TPM wurde deaktiviert.

Weshalb hast du TPM deaktiviert?

Edited by CMMAP

Share this post


Link to post
Share on other sites

@CMMAP

Die Originaltreiber der Hersteller hatte ich schon installiert. Das war das erste was ich gemacht habe (vgl. oben). Das hatte ich nicht klar beschrieben.

TPM ist deaktiviert weil ich keine verschlüsselten Platten brauche/will. Windows neigt dazu bei Feature Updates alles mal eben auf Default zu setzen und verschlüsselt dann halt einfach ohne zu Fragen. TPM ist hier aber auch nicht das Thema. Wenn es das wäre dann wäre es ein schwerer Designfehler.

Ich frage jetzt mal zurück, hast du ebenfalls den OLED Monitor? Was sagt dxdiag was deine erste GraKa ist? Wie aus dem Link zum Dell Support hervor geht ist die Intel HD wohl primär verdrahtet zum internen Monitor.

Die Aussage im HP Video ist richtig, die Intel HD als "erste" Grafikkarte scheint die Leistung zu bremsen.

Lasse ich die Programme über einen externen Monitor laufen steigt die Framerate, abweichung ca. 30-40 Frames mehr auf dem externen Monitor (siehe Screenshots).

 

 

Monitor Extern.jpg

Monitor Intern.jpg

Share this post


Link to post
Share on other sites
vor 8 Minuten schrieb Romuluz:

hast du ebenfalls den OLED Monitor?

Ja, ich habe den OLED Monitor verbaut. Bei mir ist die Intel  HD auch die erste Grafikkarte. Sobald ich bspw GRW spiele wechselt er ohne Probleme auf die GTX 1060 um.

Share this post


Link to post
Share on other sites

Habe auch ein 13"R3 mit OLED.Keine Probleme beim Umschalten der Grafikkarten.Spiele aber meist mit externem 34" und angeschlossenem AGA mit ner 1080ti.Seit ich zum Grafikupdate Nvidia Experience verwende gibts keine Probleme mehr.Habe nach Anfangsschwierigkeiten mein System 2mal neu aufgesetzt ,um Ballast loszuwerden.Jetzt nerven nur noch Win-Updates,die ungefragt neue Treiber installieren,worauf dann mal meine Toneinstellungen oder die Wlanverbindung verschwinden.Auch die Samsung NVME Treiber funzten erst nach Neuinstallation.Aber nie mehr Grafikprobleme gehabt.

Share this post


Link to post
Share on other sites

Moin Moin, also hatte ich bei meinem 13R3 auch. Funktioniert deine Helligkeitsregelung am Display ? (sicher nicht - wenn doch hast du weder Hardware noch Software Problem - dann sind es deine Games die die Optimus nicht unterstützen ! Desweiteren ist für Pinball etc keine NVIDIA nötig da die HD auch mit 2GB bedient wird du hast also genügend Ressourcen)

Folgende Maßnahme: hol dir den aktuellen Treiber für die Intel HD vom Hersteller Intel und die für deine Nvidia. Danach ist ganz wichtig. Notebook vom Internet trennen !

Alle Treiber deinstallieren für NVIDIA und Intel. danach neuboot des Gerätes. Warte danach kurz ab bis Windows seine Blöden "zertifizierten" Treiber versuch zu installieren. Sollte Windows nicht schaffen da ja kein Internet. Also wirfst Du deine Intel HD Installation an. Danach Neustart und NVIDIA hinterher. Danach sollte es laufen.

Problem ist auch wenn du NVIDIA und IntelHD von Dell holst versucht Windows 10 ja uptodate zu bleiben und zieht zertifizierte Treiber die aber nicht laufen und älter sind als die originalen Intel. 

PS es gibt für das OLED auf der DELL Seite auch spezielle Treiber, die sind aber eigentlich nicht wichtig.... Problem sollte hier also "nur" der Treiber von der IntelHD sein - aber auch nur wenn die Helligkeitsregelung nicht geht ! 

 

Share this post


Link to post
Share on other sites

Morgen, gestern nacht habe ich die Lösung für die falsche Darstellung gefunden: Die Scalierungseinstellungen des jeweiligen Programms muss auf "Anwendung" stehen, dann klappts auch mit hohen Einstellungen. Trifft halt in der Hauptsache für ältere Programme zu (DX7-9).

Der Helligkeitsregler funktioniert. Insofern ist da wohl alles "richtig" mit meiner Installation. Das manche Programme nicht mit Optimus umgehen können wird wahrscheinlich der Grund für einige der anderen Fehler z.B. beim Setup von Pinball Arcade oder Fallout 4 sein. Im DX11 Modus greift das Programm auch anscheinend auf die NVIDIA zu, zumindest wenn ich dem kleinen NVIDIA Aktivitätscenter glauben darf.

Warum du glaubst das "Pinball" keine NVIDIA benötigt erschliesst sich mir hier allerdings nicht. Zum Vergleich mit oben siehe Screenshot: 40 FPS zu 180 bzw. 210. (G)RAM ist hier nicht alleine entscheident. Aber das ist ein anderes Thema ;)

Im Grunde ist mein Problem damit (augenscheinlich) gelöst, Skalierung funktioniert, Programme nutzen die richtige Grafikkarte auch wenn im Setup was anderes steht.

Was bleibt ist die Frage nach einem FPS Monitor Tool das mir die als Overlay zb. auch die genutze Grafikkarte anzeigt, da ich das doch jetzt zunächst mal im Auge behalten möchte. Mit MSI Afterburner hatte ich meine Probleme in der Vergangenheit. Auch weiss ich nicht ob es mit der Intel HD kompatibel ist. Fraps gibt zuwenig Informationen an. Hat jemand einen Vorschlag?

Was derzeit offen bleibt ist die Frage warum bei einem auf Hochleistung ausgelegten Gaming Notebook die technische Architektur so gewählt wird das die Leistung durch schwächere Komponenten ausgebremst wird. Aber das wissen wohl nur die DELL Technikgötter selbst.

FPINTEL.jpg

Share this post


Link to post
Share on other sites

Also ich sehe das Thema gar nicht so als unverständlich an. Solange Optimus entscheiden darf oder die Anwendung selber wird das ALIEN je nach "Energiesparplan" die richtige Lösung für sich aussuchen. passt einem das nicht, ist kein Netzteil dran oder 100 andere dinge passen grad net zamm...kommt die HD um einfach mal "ausgeglichen" mit dem Notebook zu arbeiten. Im anderen Fall würdest Du Dich ja auch aufregen wenn Solitär ständig mit der 6GB NVIDIA 1060 startet und dein Akku leer brät und das noch im Akku Modus....

Wenn Du willst Das Deine Games generell mit NVIDIA Laufen dann schalte es in den 3D Eigenschaften von Nvidia frei...alternativ in den Experience Eigenschaften, oder starte Deine Games mit Rechtsklick - Ausführen mit Grafikprozessor - NVIDIA und gut ist.

Ich finde es Gut das bei ALIENS Optimus verbaut ist, ich selber nutze die HD 90% und 10% für Renderings, Animation oder Physiks…..aber bestimmt nicht im Akku Modus. 

Jeder muss sein System selbst so einstellen das er glücklich damit wird, das wird Dir auch jeder bestätigen...oder jeder der auch fremde Optimus Systeme betreibt...HP Envy, Lenovo 320 IP, Microsoft, usw usw,

Share this post


Link to post
Share on other sites

@Jörg: Super Tipp, danke!

@NOMAAM: Deine Aussgage ist für sich genommen richtig, passt aber hier nicht zum Kontext. Unabhängig vom Benutzerverhalten bezog sich mein letzter Kommentar auf den Dell Supportthread, das HP Video, meine eigenen festgehaltenen Ergebnisse und die Tatsache das ich die INTEL HD aus technischen Gründen nicht im BIOS deaktivieren kann. Meiner Meinung nach sind 15 bis 20% Leistungseinbuße keine Kleinigkeit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Please note following information: Terms of Use, Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.