Zum Inhalt springen

Treiber von nVidia modifizieren


Fufu
 Teilen

Empfohlene Beiträge

Genau da liegt der Hase begraben, bei den letzten neusten beiden Treiber ging das eben nicht mehr zu einfach... hab es nach Anleitung gemacht, aber bricht dann trotzdem mitten in der Anleitung an, Treibersignatur hab ich wie hier beschrieben aktiviert: http://praxistipps.chip.de/windows-10-treibersignatur-deaktivieren_39934

Link zu diesem Kommentar
Auf anderen Seiten teilen

So hat das bei mir nie geklappt, musste immer zweimal während der Prozedur rebooten. So hab ich das immer gemacht:

  • Drücken Sie gleichzeitig auf die Tasten [Windows] und [X]
  • Wählen Sie hier die Option "Eingabeaufforderung (Administrator)" und bestätigen Sie die Abfrage mit "Ja"
  • Im neuen Fenster geben Sie den Befehl "BCDEDIT –Set LoadOptions DDISABLE_INTEGRITY_CHECKS" ohne die Anführungszeichen ein und bestätigen Sie mit [Enter]
  • Geben Sie anschließend den Befehl "BCDEDIT –Set TESTSIGNING ON" ein und bestätigen Sie erneut mit [Enter]
  • Reboot
  • gemoddeten Treiber als Admin installieren
  • Drücken Sie gleichzeitig auf die Tasten [Windows] und [X]
  • Wählen Sie hier die Option "Eingabeaufforderung (Administrator)" und bestätigen Sie die Abfrage mit "Ja"
  • Geben Sie anschließend den Befehl "BCDEDIT –Set TESTSIGNING OFF" ein und bestätigen Sie mit [Enter]
  • Reboot
Link zu diesem Kommentar
Auf anderen Seiten teilen

  • 10 Monate später...
  • 9 Monate später...
  • 4 Wochen später...

Tach Leute,

nachdem ich meinen M17x R3 ne Weile nicht mehr genutzt hab, wollt ich ihn jetzt für ne Geschäftsreise wieder auf Vordermann bringen. Leider scheint treibertechnisch einiges im Argen zu sein: In den Apps wird mir zwar ein installierter 372.54 angezeigt, aber im Gerätemanager steht unter Grafikkarte nur "Microsoft Basic Display Adapter". Zocken ist im jetzigen zustand auch nicht drin. Bei Assassins Creed Rogue komme ich bis ins Hauptmenü und habe dann 1 FPS, bei XCOM 2 bleibt im Hauptmenü der Bildschirm einfach schwarz... Also wollte ich jetzt erstmal den Grafiktreiber erneuern...

Da ich mich leider - Asche auf mein Haupt - nicht mehr daran erinnere, welche Grafikkarte ich vor drei Jahren nachgerüstet hab, kann ich auch nicht das im Eingangspost beschriebene Verfahren nutzen, um die Hardware-ID der Graka zu ermitteln. Ich glaube, dass es ne GTX 460M ist, bin mir aber nicht zu 100% sicher...

Meine Fragen also:

1: Wie finde ich nun die genaue Bezeichnung der GraKa heraus, wenn sie nicht im Gerätemanager steht?

2: Welchen "Baustein" hat das M17x R3? Im Eingangspost wird ja angegeben, dass 043A = M17xR2.

Besten Dank schon mal für die Unterstützung!

Link zu diesem Kommentar
Auf anderen Seiten teilen

  • 3 Wochen später...

Die Hardware ID findest du im Geräte Manager. Da kannst du zumindest googlen was du für eine Grafikkarte hast (wenn du dir unsicher bist).

Rechte maus auf die standard VGA und dann Eigenschaften. Dort dann auf Details und dann in der Auswahlliste auf die Hardware IDs und dann hast du deinen Wert für die Modifikation.

 

Link zu diesem Kommentar
Auf anderen Seiten teilen

  • 3 Wochen später...

Hey, bin neu hier im Forum & habe mal ne frage, ich hab den Alienware M17xR2 oder 3 weiss gerade nicht,  & seid ca. 2 Jahren eine GTX 880M verbaut, hab noch einen alten Treiber drauf laufen (v. 347.xx) der mir beim kauf der Grafikkarte mitgegeben wurde damit ich die Graka installieren kann weil ich 0 Plan davon hab. Hab mir jetzt den aktuellsten mal heruntergeladen Version 385.xx aber schaffe es nicht den richtig zu modifizieren, hab alles nach Anleitung gemacht & wenn ich "Setup.exe" starte schlägt es schon bei der Systemprüfung fehl. Steht keine kompatible Hardware gefunden.

Laut Gerätemanager sind meine Daten wie folgt:

Nvidia= VEN_10DE

GTX 880M=DEV_1198

M17xRx=0580

Dell=1028

 

Da der installierte Treiber mitlerweile 2,5 Jahre alt ist wollt ich einfach mal nen neuen Installieren um zuschauen ob ich mehr pkt in nem Benchmark rausholen kann oder ob
Nvidia meine alte Graka schön kaputt patcht ^^ 

 

Hat jemand noch Ideen? Habe die zwei Zeilen an die richtigen Positionen reingeschrieben & auch den Eintrag der bei W10 stand beachtet das man seid Dez.2016 bei Windows 10 noch eine weitere 

Zeile hinzufügen muss an der bestimmten Position. 

 

MfG

Tolik

 

 

Link zu diesem Kommentar
Auf anderen Seiten teilen

Hast du die Treibersignatur schon deaktiviert? Das benötigst du ebenso. Eine Anleitung gibts hier im Forum.

Unter Windows 7 bspw. wird man gefragt ob man den Treiber dennoch installieren will, Windows 10 macht das nicht.

Link zu diesem Kommentar
Auf anderen Seiten teilen

  • 6 Monate später...

Guten Tag zusammen,

Ich bin am Ende meiner Reise angekommen.

Hatte mir einen AW M17xR3 gekauft welcher bereits mit eine NVIDIA 6**GTX ausgestattet war. Dazu war es bereits nötig das ein Modding im Treiber stattfindet.

(Edit: windows 7/700GB HDD/NVIDIA 6**(690m?)Startet derzeit im Abgesicherten Modus damit man die Grafikkarten iD überhaupt einsehen kann da er sonst nicht einem fingerbreit im Boot kommt und das BiOS dann auch nichtmehr zugänglich ist)

Die Verbaute Grafikkarte(blau) ist keine Dell/AW Karte. Ich habe es nun geschafft die Grafikkarte im ekngebauten zustand auszulesen; GeräteManager zwecks Hatdware ID. Mei. Problem ist dabei jetz nicht diese in die Zeilen der nvdmn.inf datei zu setzen. 

 

Mein Problem ist es die ID so anzulegen das diese vom Installationsprogramm auch erkannt wird.

Ich hoffe das hier wer was mit der Hardware ID anfangen kann und mich bei der Treiber Installation unterstützen kann.

Anbei die Hatdware ID als Bilddatei.

Bin wirklich nur ein Laie konnte vor 10 Jahren Computer zusammenbauen aber Softwaretechnisch habe ich einfach wirklich "0" drauf. 

 

Danke sage ich schonmal an alle die sich diesen Post durchlesen da dieses problem an für sich hier ja schon gelöst wurde, ich aber zu blöd bin das umzusetzen :/

 

EEFD0E09-BFA4-4F7D-A0DD-8318EBFD1A37.jpeg

Link zu diesem Kommentar
Auf anderen Seiten teilen

Hi skat,

deine im M17R3 verbaute Graka ist eine GTX 870m.

Um diese zwei Einträge solltest du  deine nvdmi.inf  lt. obiger Anleitung ergänzen:

 

%NVIDIA_DEV.1199.0490.1028% = Section033, PCI\VEN_10DE&DEV_1199&SUBSYS_04901028

 

NVIDIA_DEV.1199.0490.1028 = "NVIDIA Tuschkasten GTX 870M"

 

Falls du es selber nicht hinbekommst lade deine orig. nvdmi.inf hier als Anhang hoch, dann ergänze ich sie dir.

 

Beachte evtl. auch folgendes:

Am 11.10.2013 um 14:59 schrieb Angus:

 

  • Wenn noch nicht geschehen BIOS A12 unlocked installieren und "optimal defaults" laden
  • Alle nVidia Treiber deinstallieren
  • (Alte Grafikkarte entfernen)
  • (Neue Grafikarte einbauen)
  • Beim ersten Systemstart direkt das BIOS öffnen
  • --> "IGD" deaktivieren (--> Kein Optimus mehr! )
  • --> "PEG for primary Display" setzen
  • --> "Advanced" --> "always enable PEG" und den Punkt für "allow more time for PEG to be detected" auf enable setzen
  • Integrated HD Audio deaktivieren (es soll Karten geben die diesen Schritt nicht brauchen --> im Falle der Deaktivierung funktioniert das komplette integrierte Audio nicht mehr wie bereits geschrieben --> ausweichen auf externe USB-Lösungen)
  • Einstellungen speichern und System neustarten
  • aktuellen nVidia Grafikkartentreiber mit modifizierter *.inf installieren (unter Win8 muss die Treibersignierung vorher deaktiviert werden)
  • Neustarten und fertig

 

 

 

Bearbeitet von dude08/15
Link zu diesem Kommentar
Auf anderen Seiten teilen

Dude08/15,

zunächst einmal vielen vielen Dank.

Der Treiber lies sich installieren mit den von dir geteilten Hardware Informationen.

Sie wird nun als 870GTX im GeräteManager gelistet.

TipTop!

Wenn ich nun einen normalen Systemstart durchführe geht es bis zum: Windows Läd...

Daraufhin müsste dann die PW abfrage kommen, Bild ist Schwarz/bzw. Weiss4481A398-EC95-4738-B131-9E1CF14E8C65.thumb.jpeg.3baf4ffb0e8ece8b7c9f410c93ac1106.jpeg aber nicht abgestürzt. Das mag jetz natürlich mit daran liegen das ich kein Unlocked BIOS A12 drauf habe.(Standard A12) läuft aber auf PEG und Interne Grafik ist mit disabled gegraut.

Auch im BIOS wird die Grafikkarte folgenrichtig angezeigt.

Ich gehe davon aus das sich dieses Problem dann mit der BIOS Mod beheben lässt, muss ich mal schauen wo ich das geladen bekomme.

 

Aber alles in allem bin ich ein riesen großes stück weiter.

Dafür wirklich: Nochmal großes Dankeschön! 

 

C2E424EA-C8C1-4D2E-98B0-5E96F3F7F66F.jpeg

Link zu diesem Kommentar
Auf anderen Seiten teilen

vor 3 Stunden schrieb dude08/15:

Dies sollte dann helfen:

Integrated HD Audio deaktivieren

Grüße an den God Father himself

Dude08/15 made my day!

Nachdem ich aus dem Forum(hier) die unlocked BIOS Version geladen habe (A12) und ich daraufhin die grafikkarte wieder einsetzte und den Integrated HD Audio Reiter auf Disabled gesetzt habe läuft er nun wie eh und je. Zwar war der damals mit Sound, aber was soll ich mich beklagen?! Diese Hilfe die man mir hier geboten hat ist sehr Ehrenhaft und da möchte ich ,auch wie zuvor schon, Danke sagen ;)  vielen Dank

Link zu diesem Kommentar
Auf anderen Seiten teilen

  • 3 Monate später...

Top Anleitung, herzlichen Dank!

Eine Anmerkung: die angegebene Zeile [NVIDIA_SetA_Devices.NTamd64.6.1] für Win7 lautete bei mir nur  [NVIDIA_Devices.NTamd64.6.1], also ohne "SetA_". ?

Link zu diesem Kommentar
Auf anderen Seiten teilen

Danke, auch für den Hinweis. Ich muss mir die Anleitung nochmal vornehmen und aufräumen. Da hat sich seit Win7 doch sehr viel geändert.

So wird beispielsweise im aktuellen Treiber das Verzeichnis gelöscht, wenn die Installation abgebrochen wird. Um dies zu verhindern muss man es, bevor es gelöscht wird kopieren.

Link zu diesem Kommentar
Auf anderen Seiten teilen

  • 1 Monat später...

Servus...

 

Kann das sein das im NVIDIA- Treiber was geändert wurde das man noch eine andere Datei modden muss als NVDMI????

 

Ich habe versucht den neuesten Treiber (398.98) zu installieren.

 

Habe die NVDMI so geändert wie sonst auch.

Auch so gestartet wie es soll. 

Er kommt auch in der Treiberinstallation bis zu dem punkt wo er fragt, ich kenn den Treiber nicht soll ich trotzdem installieren, da klicke ich auf jo mach....

 

und dann kommt das Fenster mit Treiberfehler.

 

 

Jetzt die Frage, muss ich noch andere Dateien als die NVDMI ändern?

 

Ich habe einen M17X-R4 und eine GTX765 verbaut

Link zu diesem Kommentar
Auf anderen Seiten teilen

Nachtrag: Ich habe mein Problem gelöst.

Es lag daran das ich immer die NVDMI.Ini die ich mir gespeichert habe immer den Treiber reingeladen habe und dann ging das.

 

Ich habe meine ini Datei mit der original Datei im Aktuellen Treiber verglichen und dann viel es mir wie schuppen von de Kopp :)

 

 

Also meine GPU daten in die ini Datei reinkopiert und schwupps…………...alles gut :)

Link zu diesem Kommentar
Auf anderen Seiten teilen

Ich habe mich auch recht intensiv mit dem Modifizieren von nVidia Treibern beschäftigt da ich einige Probleme mit einer GTX 880m in einem m17x R4 hatte. Dabei ist mir aufgefallen, dass das modifizieren der Treiber von Hand recht aufwendig ist, teilweise aus dem Grund den @Fufu beschrieben hat, aber auch weil der Installer nicht mehr starten wollte nachdem ich den entpackten Ordner kopiert und dann die ini modifiziert hatte.

Letztendlich bin dazu übergegangen schon modifizierte Treiber zu installieren. Eurocom hat eine tolle Sammlung von modifizierten Treibern die auf viele Kombinationen von Aliens und Grafikkarten zutreffen: http://downloads.eurocom.com/support/drivers/upgradeyourlaptop/Alienware/

Damit hat man nicht immer den aktuellsten Treiber, dafür hat es bei mir aber immer ohne Probleme funktioniert und mir viele Nerven gespart :D

Link zu diesem Kommentar
Auf anderen Seiten teilen

Wichtig ist auch, daß man den Ordner direkt auf den Desktop kopiert und nicht irgendwo anders hin. Dann funkt nämlich die Rechteverwaltung dazwischen und der Installater lässt sich net starten obwohl man als Admin angemeldet ist und per rechter Maustaste "als Admin starten" auswählt.

Gruß

Link zu diesem Kommentar
Auf anderen Seiten teilen

  • Angus hat Thema abgepinnt

Deine Meinung

Du kannst jetzt schreiben und Dich später registrieren. Wenn Du ein Benutzerkonto hast, melde Dich bitte an, um mit Deinem Konto zu schreiben.
Hinweis: Dein Beitrag muss vom Moderator freigeschaltet werden, bevor er sichtbar wird.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Nur 75 Emojis sind erlaubt.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

 Teilen

×
×
  • Neu erstellen...

Wichtige Information

Please note following information: Nutzungsbedingungen, Datenschutzerklärung and Community-Regeln. Wir haben Cookies auf Deinem Gerät platziert. Das hilft uns diese Webseite zu verbessern. Du kannst die Cookie-Einstellungen anpassen, andernfalls gehen wir davon aus, dass Du damit einverstanden bist, weiterzumachen.